Indexed I/O Customer Security Notice: OpenSSL Heartbleed

As Chief Executive Officer at Indexed I/O I wanted to contact our customers and provide you information and details about the recent Heartbleed OpenSSL vulnerability and our response to this threat.

Heartbleed is a serious defect in OpenSSL, a core cryptographic library that is used to protect communications on the Internet. This flaw affects a substantial number of applications and services running on the Internet, including Indexed I/O.

Indexed I/O proactively responded to the Heartbleed threat and has patched all servers to eliminate the vulnerability. In addition we revoked, re-keyed and re-issued certificates as a matter of best practice.

After a system audit we found no evidence that Indexed I/O user credentials were compromised in any way, but as a precautionary measure we recommend that our customers change their passwords.

Security is paramount in the service we provide for your organization. Our team will continue to monitor this issue and provide more information or any other details as necessary.

If you have concerns related to the security of your Indexed I/O account, please contact us at support@indexed.io.

Sincerely,

Brian McHughs

Chief Executive Officer